ChangeLog 最新ページ / カテゴリ最新ページ / 1 2 3 次ページ / page 1 (3)

Gentoo - あかぴのChangeLog by rchalow

gentoo-suorces-3.14.16あたりでの無線LAN設定 [Gentoo]

最近GentooをインストールしたノートPCには
Intel(R) Centrino(R) Wireless-N + WiMAX 6150 が載ってるようなのだが、
なかなか使えるようにならなかったのでメモ


wpa_supplicant_wlp4s0="-Dnl80211" がキモだったんだろうな。。
  
まずdmesgにwlan0が登場しないと話にならない
すぐにwlp4s0に改名されるけど(苦笑)
gentoo-suorces-3.14.16も出たようなのでカーネル再構築する
genkernel --bootloader=grub --xconfig all
   CONFIG_IWLWIFI_DEBUGFS
   CONFIG_IWLWIFI_DEVICE_TRACING
を有効にする
/boot に新しいカーネルができてることを確認して
grub2-mkconfig -o /boot/grub/grub.cfg
これでカーネル関係おわり
一度再起動してiwconfigとifconfig。wlp4s0的なものがあることを確認
    
emerge wpa_supplicant
  
/etc/conf.d/net 編集
modules_wlp4s0=("wpa_supplicant")
wpa_supplicant_wlp4s0="-Dnl80211"
config_wlp4s0="dhcp"

cd /etc/init.d
ln -s net.lo net.wlp4s0
rc-update add net.wlp4s0 default

これで再起動するか、
etc-update
/etc/init.d/net.wlp4s0 restart
で無線LANの電波を拾うようになるはず。


ibusとmozcは以下のblog通りに設定したらうまくいったみたい。
なかゆきの気まぐれ日記
  Gentooで日本語入力ハマったのでメモ
    http://blog.nakayuki.net/linux/gentoo-japanese/


1257日後

emerge worldしたらX立ち上がらくなった理由 [Gentoo][SC420]

xf86-video-intelをダウングレードしようとしたがダメ。X自体がupdateしたから?
xf86-video-intel-2.14.0を一度消して、再emergeしてみたら、

カーネルのKMSを有効にしろ!
と出てた。
別なパーティションのgentooはxf86-video-intel-2.9.1みたいだ。

Gentoo 10.0 LiveCDのフレームバッファ [SC420][Gentoo]

GentooのLiveCDはvesafbでframebufferを実現してるのね。ubesafbかと思ってた。

フレームバッファが無効だと、SC420の起動コンソール画面がはみ出して見にくいので(VGA 600x480)

E7221とかi915のせい?(苦笑
LiveCDと同じ1024x768にするべく格闘中。
  
11/3追記:
  LiveCD、minimal-instCDともに/proc/config.gzを使ってカーネルコンパイルすれば
  vesafb対応のカーネルができることが確認できました。
  無事フレームバッファに成功。

Plamo-4.73でDVDを焼く [Plamo][Gentoo]

はじめてLinux上でDVDを焼いてみた(笑)
Windowsのソフトより速いし安定感あるな。
CDのisoイメージをDVDに焼いても起動できるのね。

~$ sudo cdrecord -scanbus
Cdrecord-ProDVD-ProBD-Clone 2.01.01a75 (i686-pc-linux-gnu) Copyright (C) 1995-2010 J g Schilling
Linux sg driver version: 3.5.34
Using libscg version 'schily-0.9'.
scsibus0:
0,0,0 0) 'ATA ' 'ST380013AS ' '8.12' Disk
0,1,0 1) *
0,2,0 2) *
0,3,0 3) *
0,4,0 4) *
0,5,0 5) *
0,6,0 6) *
0,7,0 7) *
scsibus4:
4,0,0 400) 'ATA ' 'ST380011A ' '3.16' Disk
4,1,0 401) '_NEC ' 'DVD_RW ND-3540A ' '1.22' Removable CD-ROM
4,2,0 402) *
4,3,0 403) *
4,4,0 404) *
4,5,0 405) *
4,6,0 406) *
4,7,0 407) *

~$ sudo cdrecord dev=4,1,0 -data download/livedvd-x86-amd64-32ul-10.1.iso
cdrecord: No write mode specified.
cdrecord: Assuming -sao mode.
cdrecord: If your drive does not accept -sao, try -tao.
cdrecord: Future versions of cdrecord may have different drive dependent defaults.
Cdrecord-ProDVD-ProBD-Clone 2.01.01a75 (i686-pc-linux-gnu) Copyright (C) 1995-2010 J g Schilling
scsidev: '4,1,0'
scsibus: 4 target: 0 lun: 0
Linux sg driver version: 3.5.34
Using libscg version 'schily-0.9'.
Device type : Removable CD-ROM
Version : 5
Response Format: 2
Capabilities :
Vendor_info : '_NEC '
Identifikation : 'DVD_RW ND-3540A '
Revision : '1.22'
Device seems to be: Generic mmc2 DVD-R/DVD-RW/DVD-RAM.
Using generic SCSI-3/mmc CD-R/CD-RW driver (mmc_cdr).
Driver flags : MMC-3 SWABAUDIO BURNFREE
Supported modes: TAO PACKET SAO SAO/R96R RAW/R96R
cdrecord: Warning: Cannot read drive buffer.
cdrecord: Warning: The DMA speed test has been skipped.
Starting to write CD/DVD/BD at speed 4 in real SAO mode for single session.
Last chance to quit, starting real write 0 seconds. Operation starts.
Turning BURN-Free off
cdrecord: WARNING: Drive returns wrong startsec (0) using -150
Track 01: Total bytes read/written: 116617216/116617216 (56942 sectors).
~$


Gentoo 10.0で Rabbit [Gentoo][Rabbit][SC420]

ショッカーのおつとめとして Rabbitをインストしてみた。
前に試したのは4年前か[2006-09-04] 今回はGentoo 10.0 が相手です。
  
  ACCEPT_KEYWORDS=~X86 emerge rabbit

emerge: there are no ebuilds built with USE flags to satisfy ">=sys-fs/udev-146[extras]".
!!! One of the following packages is required to complete your request:
- sys-fs/udev-162 (Change USE: +extras)
と言われちゃった。udev-162をインストしても大丈夫なのか迷ったが
/etc/portage/package.use に
sys-fs/udev extras
を追記して再度emerge。無事成功しました。まだ Ver0.90には上がってないけども。
画像

10/7追記:適当にebuildを作って無理矢理 Rabbit-0.9.0にしてみた。
mkdir /usr/local/myportage
chown …
make.confに追記
PORTDIR_OVERLAY="/usr/local/myportage"
/usr/portage/app-office/rabbitの中身を/usr/local/myportage/app-office/rabbitにコピー
/usr/local/myportage/app-office/rabbit/rabbit-0.6.4.ebuild から rabbit-0.9.0.ebuildを作成
sudo ACCEPT_KEYWORDS=~X86 emerge rabbit
これで成功した。
rabbitの前に ruby-gnome2-0.90.2.ebuild も同じ方法でやろうとしてた。
こっちは
   sudo ebuild ruby-gnome2-0.90.2.ebuild marge
いいのか分からんがちゃんと終った。

続SC420にGentoo/パワージューサー [SC420][Gentoo][ひとりごと]

墓参りも済んでるし、雨がひどいし、家から出ない祝日。

emerge -pv --update --deep --newuse world
  [blocks B ]lzma-utilsなので
emerge -C lzma-utils
そしていよいよ
emerge --update --deep --newuse world
  133個更新されるみたい。
emerge --depclean
revdep-rebuild
etc-update
余計なモジュールが起動されるのを減らす
genkernel の ロードする kernel モジュールを最低限にする。
   http://insnvlovn.blogspot.com/2009/11/genkernellsmod.html
/etc/modules.autoload.d/kernel-2.6 修正
/usr/share/genkernel/arch/x86/modules_load も修正
sudo genkernel initramfs
emerge xorg-x11 して xorgが起動するとこまで終りました。
再度
emerge --update --deep --newuse world
  5個更新
emerge --depclean
revdep-rebuild
普段使いはPlamoなので暇ができたらまたいじりましょ。

パワージューサーたぶん到着しただろう。

9/24追記:
親戚んちでは、誰から送られてきたものか分からず大騒ぎになっていたそうだ。
業者に電話して確認したとのこと(苦笑

SC420にGentoo [SC420][Gentoo][Plamo]

連休前からGentoo熱が。
なぜかパーティションは準備してあった(笑)[2009-05-18]
Plamo-4.73からchrootしてインストール。
genkernelの途中でlzmaコマンドが無いというエラーで止まったので

emerge lzma-utils
これでgenkernelも成功!
デュアルブートで起動できるとこまで完了。
やっぱgenttoのインストは神経使う。風呂とポン酒で疲れを癒す(笑)

2007.0でエラーが出たら [Gentoo]

Called dyn_compile
などと出たら
emerge -C x11-server
emerge -C xorg-x11
X 関連を一度消して再度emergeしてみたほうがいいようだ。

ログインできない [Gentoo]

久しぶりにkiku3号を起動してみたらgentooとPlamoのデュアルブートになってた。# 全然覚えていない(笑)
Plamoは2度目で起動した。gentooは、ちゃんと起動するのだがログインできない。
しばらく四苦八苦したが、PAM?認証システム?を殺してしまってログインできなくなって
放ったらかしにしたままだったような記憶があるようなないような…。

2006.1 [Gentoo]

installcdなのに K6マシンでchrootできない。2006.0でもダメ。
なぜか 1.4だとOK

# chroot /mnt/navynos /bin/bash
Illegal instruction
stage3-586系じゃないとダメなのか?
livecdを試すか?
マシンの問題なのか? 既知の何かなのか?

おまけに686に最適化したカーネルって K6じゃ止まるの?
  http://starboze.txt-nifty.com/into_the_linux_world/cat4600699/index.html
やっぱ586にしないとダメのようだな。
stageは586かx86
make.confのCHOST、CFLAGSも見直しが必要ね。

GentooでRabbit [Gentoo][Rabbit]

X Error of failed request: GLXBadContext…
libglx.soあたりが関係しているようなんだが、nvidiaも関係しているようなので
USE="-nvidia"、カーネル再構築して
emerge -C x11-libs/hoge系
emerge -C ruby-gnome系
emerge -C gnome系
emerge xorg-x11
してXを入れ直し。
う〜ん、簡単にはX起動しないね。
emerge libXhoge…
emerge libXhogehogehoge…
さて、どうなるか?
ACCEPT_KEYWORDS=~x86 FEATURES="digest" USE="-opengl tiff enscript example gnome-print svg tgif" emerge rabbit
cd /usr/share/doc/rabbit-0.2.9/sample
rabbit rabbit-implementation.rd
お〜 きた!! はぁ〜良かった

emerge rabbit [Gentoo]

ACCEPT_KEYWORDS=~x86 FEATURES="digest" emerge -vp rabbit
してみて、USEを追加。
ACCEPT_KEYWORDS=~x86 FEATURES="digest" USE="いろいろ…" emerge rabbit

rootの.bashrcに:
alias nomani='env ACCEPT_KEYWORDS=~x86 FEATURES="digest"'
と書いておけば、後はrootで
nomani emerge rabbit

Plamo化 [Gentoo][ひとりごと]

emerge plamo が欲しい。

emerge -C groff
/etc/portage/packe.maskに
=>sys-apps/groff-1.19
と書いて
emerge man-pages-ja

ACCEPT_KEYWORDS="~x86" emerge app-emacs/mew-4.2

glsa-check [Gentoo]

まず

emerge gentoolkit

glsa-check -p $(glsa-check -t all)
は違うみたいね。変わったんだ。
glsa-check -t new

pam-login が blockされる [Gentoo]

[blocks B ] sys-apps/pam-login (is blocking sys-apps/shadow-4.0.15-r2)
対処に悩んだのだが、あっしだけじゃなかったのね。
  http://72.14.235.104/search?q=cache:vELeNmUIgtsJ:cvzn.com/xoops2/modules/news/index.php%3Fstorytopic%3D4+portage+pam-login&hl=ja&gl=jp&ct=clnk&cd=3&lr=lang_ja

emerge -C pam-login
していいんだ。なんだー!

Gentoo Weekly Newsletter: 12 June 2006

shadowとpam-loginの競合

多くのユーザは、新しいバージョンのpam-loginとshadowがお互いにブロックする事象に遭遇しています。 /bin/loginファイルが、主に歴史的な理由からpam-loginによって提供されていることが原因です。 現在、shadow 4.0もこのファイルを提供するようになり、 混乱を避けるために言っておくと、現在このファイルはshadowによって提供されます。 また、pam-loginの残りのファイルは、shadowに同梱されています。 したがって、これら2つのパッケージがお互いにブロックする事象に出くわしたら、 pam-loginをunmergeして、最新のshadowパッケージをemergeしてください。

より詳しい情報は、 Diego Pettenのブログを見てください。


emerge xorg-x11
Xorg -configure
cp -p /root/xorg.conf.new /etc/X11
して編集
USEフラグは(/etc/make.conf で設定のこと)
  http://www.gentoo.org/dyn/use-index.xml

nVidiaのせいか、うまくXが動かん。vesaでしか。
カーネルをコンパイルし直してnVidiaモジュール作ったらいいのか?

Xをemergeする前に [Gentoo]

emerge system してやった。40個更新されるようだ。
最初は文句言われたが。

Gentooインストールの参考サイト [Gentoo][ひとりごと]

パソコンふぉあ障害者ず
http://www9.ocn.ne.jp/~pcvolu/pcnet/gentopage13.htm
前からお世話になっているのだがあらためてメモしとこ。

こっちの世界に戻ってきた [SOLO2300号][Gentoo]

ちょうど一ヶ月ぶりで
   emerge -u sys-process/vixie-cron
から戻ってきた。
etc-update して一旦休ませようとも思ったが、
再起動して、emerge sync
してやった。でもって、
  glsa-check -f $(glsa-check -t all)
の途中でバッテリートラブルで電源断してしまった。
  glsa-check -t all
は、うまくいかない。emerge -p world はすごいことになりそうだからヤメ。

最終更新時間: 2014-08-20 06:55