ChangeLog 最新ページ / カテゴリ最新ページ / 前ページ 1 2 3 4 5 次ページ / page 3 (5)

Plamo - あかぴのChangeLog by rchalow

Emacsからfirefoxへのコピペ(コピー&ペースト) [Plamo]

'.emacs' に

(setq x-select-enable-clipboard t)
追加。
http://tach.arege.net/diary/?date=20060901#p01 を参考にした。

昔から、firefox --> emacs のコピペは問題なくできていたが、
逆は無理なんだろうとあきらめていた。
これで生活が楽になる(笑)

以下も参考に
http://d.hatena.ne.jp/maluboh/20061210#p2
http://luke.skr.jp/hsj/?cmd=read&page=emacs%2FTips#content_1_3

Plamo-4.5で書き換えたファイル [Plamo]

~/.mew.el
~/.xinitrc_twm
~/.Xdefaults

/etc/fstab
/etc/sudoers
/etc/inittab
/etc/rc.d/rc.M
/etc/rc.d/rc.local
/etc/rc.d/rc.inet2
/etc/rc.d/init.d/の中で使わないデーモンはchmod -x

PlamoBuildスクリプトの使い方 [Plamo]

玩式草子─ソフトウェアとたわむれる日々
第38回 Plamo Linuxのビルドスクリプトとパッケージ管理ツール[その1]
http://gihyo.jp/lifestyle/serial/01/ganshiki-soushi/0038
  
  
もっと古い情報
こじまさんの日記より:http://plamo.linet.gr.jp/index.php?diary%2FKojima%2F2009-01-10
                            : http://plamo.linet.gr.jp/wiki/index.php?diary%2FKojima%2F2009-01-10

Plamo-4.5 [Plamo]

10/16あたりに出たようだ。

Plamo 4.5 [Plamo]

Plamo 4.5 がβテストに入った模様。

cpan> install HTML::Template [Plamo][chalow]

昨日のことだが。
ローカルマシンでchalowしようとしたらHTML::Templateが無いと怒られた。

$ sudo perl -MCPAN -e shell
cpan> install Bundle::CPAN
cpan> install HTML::Template
cpan> install Jcode
これでchalowできた。

kernel-2.6.23.16に [Plamo]

http://www.linet.gr.jp/ML/plamo/200802/msg00034.html

2.6.17 から 2.6.24.1 にかけてのカーネルで,vmsplice を悪用した local
exploit(そのマシンにアカウントを持っている人が違法に root 権限を取れる
バグ)が見つかったようです.
ということなのでカーネルをupdateしてみました。
removepkg kernel
removepkg kernel-headers
あっしは/boot をマウントしないで起動しているので
mount /dev/hda1 /boot
installpkg download/kernel-2.6.23.16_plamoSMP-i586-P1.tgz
installpkg download/kernel_headers-2.6.23.16_plamoSMP-i386-P1.tgz
で再起動。
Webでもアナウンスされてますね。
http://plamo-linux.jp/security.html#kernel_20080212

Plamo-4.22でimaps [Plamo]

予定通りインドアな生活。
k3号のIMAPS の設定が残っていたのでやってみた。

Plamo-4.2のときは stunnelをインストールすれば大丈夫だったと思うんだど、うまくいかない。
Mew version 5.2 になったからだろうか?
しばらく四苦八苦したがダメなので
原点にかえって、
  http://www.mew.org/release/info/mew_85.html.ja#SEC85
をゆっくり読む。
「"openssl" に付いてくる証明書、cert.pem」が無いので
opensslのソースを拾ってきて、tar して
./openssl-0.9.8g/apps/cert.pem
を使う。
念のため .mew.el に以下を追加。

(setq mew-ssl-verify-level 0)
(setq mew-ssl-cert-directory "~/.certs")
やっと IMAPS できたが不安定。つながったり、失敗したり。
確率50%
まる1日かかってもここまでか。

Plamo 4.22に関する記事 [ひとりごと][Plamo]

画面で見る最新Linux「Plamo Linux 4.22」
  http://itpro.nikkeibp.co.jp/article/NEWS/20071018/284923/

Plamo 4.22リリース [Plamo]

されたようです。
http://plamo-linux.jp/

/sbin/xfplamoconfig [PCG-808][Plamo]

http://www.sony.jp/ProductsPark/Consumer/PCOM/NoteA4CAT/spec.html

NeoMagic MagicMedia 256AV(NM2200)
/sbin/xfplamoconfig でいける。

参考に http://www.unixgods.org/~tilo/XF86Config.PCG808

###
### XF86Config file for SONY VAIO PCG-808 laptop
### with NeoMagic 256AV graphic chip
###

Section "Files"
    RgbPath "/usr/X11R6/lib/X11/rgb"
    FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/URW"
    FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
    FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
    FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
    FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
# ModulePath "/usr/X11R6/lib/modules"
EndSection

#Section "Module"
# Load "xf86Jstk.so"
#EndSection

Section "ServerFlags"
# NoTrapSignals
# DontZap
# DontZoom
# DisableVidModeExtension
# AllowNonLocalXvidtune
# DisableModInDev
# AllowNonLocalModInDev
EndSection

Section "Keyboard"
    Protocol "Standard"
    AutoRepeat 500 5
# XkbDisable
    XkbKeymap "xfree86(us)"
EndSection

Section "Pointer"
# Protocol "Microsoft"
# Device "/dev/ttyS0"
    Protocol "PS/2"
    Device "/dev/psaux"
    Emulate3Buttons
    Emulate3Timeout 50
EndSection

Section "Monitor"
    Identifier "Generic Multisync"
    VendorName "Unknown"
    ModelName "Unknown"
    HorizSync 30-64
    VertRefresh 50-100

# 640x480 @ 60 Hz, 31.5 kHz hsync
Modeline "640x480" 25.175 640 664 760 800 480 491 493 525
# 800x600 @ 60 Hz, 37.8 kHz hsync
Modeline "800x600" 40 800 840 968 1056 600 601 605 628 +hsync +vsync
# 1024x768 @ 60 Hz, 48.4 kHz hsync
Modeline "1024x768" 65 1024 1032 1176 1344 768 771 777 806 -hsync -vsync

EndSection

Section "Device"
    Identifier "NeoMagic"
# Chipset "NM2160"
# IOBase 0xfea00000
# MemBase 0xfd000000
# VideoRam 2048
# DacSpeed 90
# Option "linear"
# Option "nolinear"
# Option "sw_cursor"
# Option "hw_cursor"
# Option "no_accel"
# Option "intern_disp"
# Option "extern_disp"
# Option "mmio"
# Option "no_mmio"
# Option "lcd_center"
# Option "no_stretch"
EndSection

Section "Screen"
    Driver "svga"
    Device "NeoMagic"
    Monitor "Generic Multisync"
    Subsection "Display"
        Depth 8
        Modes "1024x768" "800x600" "640x480"
    EndSubsection
    Subsection "Display"
        Depth 16
        Modes "1024x768" "800x600" "640x480"
    EndSubsection
    Subsection "Display"
        Depth 24
        Modes "1024x768" "800x600" "640x480"
    EndSubsection
EndSection


logrotate [修行][Plamo]

cronで

/usr/sbin/logrotate /etc/logrotate.conf
が実行されると /var/log/cron の中身が空のままになる。。。
logrotate.conf の include行がうまくいっていないのか? 他に何か原因があるのか?
/etc/rc.d/rc.M も関係しているかも。

http://homepage2.nifty.com/ssfu/others/computer/linux_logrotate01.html
を読んで、
/etc/logrotate.d/syslogo を改造、

/var/log/debug /var/log/maillog /var/log/messages /var/log/secure /var/log/spooler /var/log/syslog {
    sharedscripts
    postrotate
/bin/kill -HUP `cat /var/run/syslogd.pid 2>/dev/null` 2>/dev/null || true
    endscript
}

(/var/log/cron削除)

/etc/logrotate.d/cron を作成
/var/log/cron {
    missingok
    notifempty
    postrotate
# /bin/kill -HUP `/bin/cat /var/run/crond.pid`
        /usr/bin/killall -HUP crond
    endscript
}

/etc/rc.d/rc.localというスクリプトファイルの末尾辺りに、次の一行を追加します。
/usr/sbin/logrotate /etc/logrotate_local.conf
echo executed /usr/sbin/logrotate /etc/logrotate_local.conf. Done.
sleep 3

bsfilter高速化? [修行][Plamo]

mewでのbsfilterの使い勝手を調べていたら(X-spam-Flagの付いたメールに*マークだけを)
  http://www2b.biglobe.ne.jp/~caco/cf-t1.html
なページがあったので真似した。

2006/01/15(Sun)

    bsfilter自体は快調に動いているが,最近Spamデータベースが充実するにつれ,非常に遅くなってきた.メールが100通以上溜まっていると,処理するのに5分以上かかる.どうもsdbm/gdbmが遅いようだ.データベースは全部で32MBほどしかないのに困ったものだ.根本的にはPostgreSQLなどの本格的なDBを使うようにすれば解決するのだと思うのだが,そこまでする時間がないので,安直にSpamデータベースをRAMに置くことにした.まず,.bsfilterをシンボリックリンクに置き換える.

    cd
    mv .bsfilter .bsfilter.back
    ln -s /mnt/tmpfs/.bsfilter .

    rc.localに以下を設定.

    mount -t tmpfs -o size=64m /dev/shm /mnt/tmpfs
    cp -p /home/t-ishii/.bsfilter.back/* /mnt/tmpfs/.bsfilter &

    次にcrontabを設定して5分毎にRAM上の内容がHDDにバックアップされるようにする.

    0-55/5 * * * * /usr/bin/rsync -a /mnt/tmpfs/.bsfilter/* /home/t-ishii/.bsfilter.back

    これでだいぶ快適になった.

/etc/rc.d/rc.localは ちょっと変更を多くしたような気が。。
なんだかcronもどうにかしないと。
ついでにcrondのloglevelも変更

すごくbsfilterの動作が軽くなりました!

Rabbit-リポジトリ版 [Plamo][Rabbit]

らびっとゆーざずぐるーぷ「ショッカー」のML
     http://www.cozmixng.org/~w3ml/index.rb/rabbit-shockers/
で教えてもらったところ、リポジトリから引っ張った方がいいらしい。

svn co http://www.cozmixng.org/repos/rabbit/trunk rabbit
これはうまく動きました。
というわけで、Plamoな方はリポジトリ版をインストールしましょう!

いつもありがとうございます>kouさま

Plamo4.2でRabbit動きました [Plamo][Rabbit]

頭を整理して全部やりなおしてみました。

・まずPlamo4.2をインストール
    おまかせパッケージのM(普通に使うには困らない環境)を選択

・ruby-1.8.5.tar.gz のインストール
    $ ./configure
    $ make
    # make install
    $ make clean

・rdtool-0.6.20.tar.gz のインストール
    # ruby setup.rb

・ruby-gtk2-0.15.0.tar.gz のインストール
    $ ruby extconf.rb
    $ make
    # make install
   で、以下を試す

$ ruby -e "require 'gtk2'"
    $ ruby -e "require 'gtk2';Gtk::Window.new.set_title('Hello Ruby-GNOME2 World!').show;Gtk.main"

・rabbit-0.4.1 のインストール
何でだか分からないけど最新の rabbit-0.4.2 は動かない。
   # ruby setup.rb
cd rabbit-0.4.1/sample/
rabbit rabbit-implementation.rd
これでサンプルが動きます。
ただし、以下のエラーがコンソールに出ますけど無視。
/usr/local/lib/ruby/site_ruby/1.8/rabbit/ext/enscript.rb:6: command not found: enscript --help-highlight
[2006-10-01] に続編あり

plamo4.21β2 [Plamo]

カーネル2.6.15? iso間違えたか?
とりあえず

xfplamoconfig

iso間違ってないかチェック。間違ってたら焼き直し。
   find /media/cdrom -mtime -150 # 150日以内に修正されたファイル
/boot から起動する方法を勉強

PlamoでRabbit [Plamo][ひとりごと]

PlamoでRabbit動かすには何が必要か?
うちはGNOME/KDEはインストールされてないからな…。
<gdk-pixbuf> すでに入ってる
== gdk-pixbuf-0.22.0 インスト。うまくいかない。==

http://www2d.biglobe.ne.jp/~yamhome/linux/plamo403.html
gdk-pixbuf-0.10.1.tar.gzを使いました。最新版ではmakeでエラーが出たので・・・)
== ということで http://ftp.yz.yamagata-u.ac.jp/pub/X11/wm/GNOME/sources/gdk-pixbuf/0.10/?C=M;O=D からダウンロード。==
== インスト成功。==

<Plamoのパッケージリスト>
  http://www.linet.gr.jp/~kojima/Plamo/recom_files.html
  http://plamo.minidns.net/

だめだ ruby-gnome のインストールができない。
おすすめのKDEを選択してやってみたほうが手っ取り早いに違いない。
GentooでRabbit動いたからとりあえず先送りしよ。

mecab-0.90 [Plamo][NetSt号]

Plamo4.2のインストール・設定はいつものようにやって、
mecab-ipadic-2.7.0-20051110 をmakeするときエラー発生。
http://lists.sourceforge.jp/mailman/archives/mecab-users/2006-February/000046.html
と同じ症状らしい。
 # ldconfig
で うまくいった。

bsfilter-1.0.12がうまく動いてくれない。
1024行目の
  @m = MeCab::Tagger.new([$0, "-Ochasen"])
で引っかかってる模様。
mecab-0.90、mecab-ruby-0.90、bsfilter-1.0.12のどれかの仕様が変わったのかもしれない。
.bsfilter/bsfilter.conf を編集して bigramを使うように変更。

最終更新時間: 2018-01-05 09:01